This page may not work correctly inside the Unity editor. Open in browser

Install or Update

Supported Versions

Nature Shaders supports all render pipelines and Unity versions with the following minimum requirements:

Render Pipeline Pipeline Version Unity Version
Standard (Built-in) 2018.4 or higher 2018.4 or higher
High-Definition 7.0 or higher 2019.3 or higher
Universal 7.0 or higher 2019.3 or higher

Install

Nature Shaders is included as an embedded package in Nature Renderer and Open World Nature Kit. As such, there is no need to install a specific package for each render pipeline. The correct package should be installed along with Nature Renderer or Open World Nature Kit.

Upgrade Materials

If you import Nature Shaders into a project that uses an older version of Nature Renderer (before 1.2.0) or Open World Nature Kit (before 1.3.0) then a prompt will show to upgrade the materials in your project to the new Nature Shaders.

Click 'Convert Materials' to convert all materials that use the legacy 'Open World Nature' shaders to the new Nature Shaders.

After converting, click 'Delete' in the next prompt to delete the legacy Open World Nature shaders from your project. These shaders are no longer supported and the Nature Shaders should be used instead.

Was this article helpful?
1 out of 2 found this helpful